07 Erros comuns ao criar fórmulas no Excel

Fórmulas no Excel | Conheça agora os 07 erros mais comuns

Fórmulas no Excel

Imagine se você, depois de gastar um tempo digitando uma (ou várias) fórmulas no Excel, ao apertar o ENTER, não viesse nenhuma mensagem de erro.

Parece um pouco difícil de acreditar que você não tem que ficar procurando letra por letra para encontrar esse erro na fórmula no Excel, principalmente quando a fórmula é extensa e complexa.

Pensando nisso, criei esse artigo com o objetivo de fazer você chegar a um nível de erro ZERO na criação de fórmulas no Excel.

Para isso, eu listei os 07 erros mais comuns cometidos durante a criação de fórmulas no Excel e, o que você deve fazer para evitar esses erros.

Vamo lá?

Erro #1 – Não fechar os parênteses

Esse erro é clássico.
Verifique se todos os parênteses usados na fórmula têm um par correspondente. Quando você cria uma fórmula, o Excel exibe parênteses coloridos à medida que eles são inseridos. Visando facilitar essa questão, o Excel (em alguns casos), já fecha automaticamente os parênteses que ficaram abertos.

Outro erro cometido em relação aos parênteses, está na criação de fórmulas no Excel. Assim como uma vírgula pode dar um sentido totalmente inverso a uma frase em Português, os parênteses colocados em lugares errados, podem alterar totalmente o resultado de uma fórmula.

Por exemplo:
O resultado dessa fórmula: =A1*(B1+C1) será diferente da fórmula =A1*B1+(C1)

Erro #2 – Digitação dos Intervalos

Para fazer referência a um intervalo de células em uma fórmula, use dois-pontos (:), em vez de outros símbolos como um travessão (-), para indicar a primeira e a última células do intervalo.

Por exemplo: Insira =A1:A5 em vez de =A1-A5.

Em fórmulas, “dois-pontos” não são usados como um operador matemático, mas um travessão (ou um sinal de subtração) sim.

Lembrando que:

“dois-pontos” representam DE -> ATÉ
Exemplo: =SOMA(A1:A5) -> Somar de A1 ATÉ A5

“ponto-vírgula” representam E
Exemplo: =SOMA(A1;A5) -> Somar A1 E A5

Acredite você ou não, esse erro é MUITO comum entre os usuários ao criar fórmulas no Excel :/


Leia também: PROCV e PROCH Passo à Passo (Sem complicação)


Erro #3 Falta de Argumentos obrigatórios

Isso geralmente acontece mais quando se está criando uma fórmula mais complexas. Para concluir uma fórmula com êxito, verifique se inseriu o número correto de argumentos necessários.

Exemplo:
=SE(A1B1;C1;D1)
Que argumento obrigatório faltou nessa função SE?

Resposta: Faltou o [teste_lógico], ou seja, SE A1 é maior, menor, igual, diferente, etc. do que B1

Correto: =SE(A1>B1;C1;D1)

Erro #4 Ultrapassar o limite de funções

Ao aninhar outras funções nos argumentos de uma fórmula que usa uma função, verifique se manteve o limite de 64 níveis de funções aninhadas nessa fórmula.
Geralmente isso acontece quando ao invés de usar a função SOMA, por exemplo, usa-se:

=A3:A6+F10+C1+D5:D201+E1+F1+G1+H1+I5:K8+J1+K1+L1+M1:N3…

Erro #5 Não fazer referências corretamente entre planilhas

Se, em uma fórmula, você fizer referência a valores ou células contidos em outra planilha ou pasta de trabalho, e o nome dessa planilha ou pasta de trabalho contiver um caractere não alfabético, coloque o nome entre aspas simples (‘).

Exemplo
Forma errada: =SOMA(A1;[Pasta2]planilha-10!A1)

Forma correta: =SOMA(A1;[Pasta2]planilha-10!A1)

Erro #6 Referências de planilhas externas

Verifique se cada referência externa inserida em uma fórmula contém um nome de pasta de trabalho e o respectivo caminho.
No meio de tantas planilhas, é bem possível confundir-se em chamar as referências externas.

Erro #7 Digitar números sem formatação

Outro erro clássico.
Verifique se não incluiu formatos de número ao inserir números em uma fórmula. Nos argumentos de fórmulas, o cifrão ($) é usado para indicar referências absolutas, e a vírgula (,) é usada como um separador de argumentos.

Portanto, em vez de inserir $1,000 na fórmula, insira apenas o número 1000.

Considerações finais

Como você pode perceber, muitos dos erros ao criar fórmulas no Excel vem de processos manuais, ou seja, o erro é humano. Por isso, para minimizar os erros, recomendo que não tente digitar uma fórmula do início ao fim “na raça”Use o mouse para buscar as referências, é muito mais fácil e rápido.

Outra recomendação é arraste as fórmulas no Excel. Use e abuse desse recurso. É muito útil. Mas fique sempre de olho nas referências, ok?

O erro faz parte do aprendizado. Nunca tenha medo de errar.

Gostou do artigo? Então, deixe um comentário.
Eu adoro receber os feedbacks e respondo pessoalmente todos eles.

  • Luiz

    mais uma vez as dicas foram show de bola… muitos desses erros são comuns mesmo. Praticar pra não errar… e mesmo que ocorra , o jeito é arrumar… valeu …

    • Olá Luiz! Muito obrigado por comentar!
      Que bom que gostou.
      Abraços!

  • Kátia

    Realmente são dicas preciosas que em muitos momentos acabamos deixando passar, e são os detalhes que costumam fazer toda diferença, não há dúvida. Parabéns pelas suas dicas e orientações. Excelente!!!

    • Olá Kátia! Agradeço muito o seu comentário aqui no Blog.
      Fico feliz por você gostar do meu conteúdo. Fique atenta, que em breve apresentarei grandes novidades 🙂

      Abraços,
      Edson Cavalcante

  • estou desenvolvendo um relatório de gestão para apresentar a meus clientes e as dicas de excel estão sendo muito úteis nessa construção. Aprendi um pouco na raça, pesquisando e tirando dúvidas com amigos, mas é sempre bom poder ter acesso a conteúdo de quem é ninha no assunto. Valeu, por compartilhar seu conhecimento.

    • Olá Carlos!
      Obrigado por seu comentário
      Fico feliz por esse conteúdo ter sido útil para você.
      Grande abraço!

  • Gloria Azevedo

    Excelente dica, amei, vou repassar para as minhas amigas, obrigada.

    • Olá Glória!
      Obrigado por comentar!

      Fico feliz em saber que você gostou.
      De nada! 🙂

  • Ótimo post, bem didático. Gostei!

  • Mássylla Oliveira

    Excelentes dicas que você nos passa, com um método simples aprendemos o básico que nos auxilia no dia a dia. Muito obrigada!

    • Olá Mássylla! Obrigado por deixar seu comentário aqui no Blog! Fico feliz que você tenha gostado 🙂
      Abraço.

  • Darcy Adriano

    Esta cada vez mais facil, entender o excel.

    • Olá Darcy!
      Obrigado por comentar! Legal saber que meu conteúdo está te ajudando a entender o Excel 🙂
      Abraço!