Aprenda a Função Não.Disp

Pouca gente sabe, mas a função Não.Disp tem sim utilidade. Vamos neste tutorial mostrar como e quando usá-la.

A função Não.Disp pode servir de extrema importância principalmente na observa o de gráficos. Esta função mostra que o valor não está disponível.

Planilha disponível para donwload

Donwload da Planilha de Excelhttps://ninjadoexcel.com.br/wp-content/uploads/2019/10/Função-Não.Disp_.xlsx

Vamos pegar nossas informações e fazer um gráfico de pizza. Para isso, selecione dos dados, clique na guia Inserir e em gráfico de pizza escolha algum que lhe agrade:

Criando Gráfico para Função Não.Disp

Agora adicionar os rótulos de dados em nosso gráfico:

Rótulos para a Função Não.Disp

Observe que como não tivemos gastos com saúde o gráfico mostra três cores, mas quatro rótulos de dados. Vamos concertar isso?

É nesse momento que entra a função Não.Disp.

Clique na célula H4 e digite =NÃO.DISP():

Aplicando a Função Não.Disp

Cadastre seu email aqui no blog para receber em primeira mão todas as novidades, posts e videoaulas que postarmos.

Receber conteúdos de Excel

Preencha abaixo para receber conteúdos avançados de Excel.

Fique tranquilo, seu e-mail está completamente <strong>SEGURO</strong> conosco!

É muito importante que você me adicione na sua lista de contatos, para que os próximos emails não caiam no SPAM. Adicione este email: edson@ninjadoexcel.com.br

Pressione Enter e veja o gráfico agora que nosso rótulo zerado acabou de sumir

Gráfico com a Função Não.Disp

 

No entanto para não ficarmos digitando esta função toda hora que precisarmos vamos automatizar usando a função SE.

Clique na célula H1 e digite: =SE(SOMA(B2:B4)=0;NÃO.DISP();SOMA(B2:B4)):

Função se dentro de a Função Não.Disp

Repita o processo com as demais áreas.

Para testarmos, apague os valores referente a área de transportes e veja que tanto os rótulos quanto as cores desapareceram:

Obviamente este recurso não se aplica somente ao gráfico de pizza como também a qualquer outro tipo de gráfico no Excel.

Fizemos numa planilha simples, mas uma aplicação muito importante desta função são em Dashboard.

Quer aprender Excel do Básico ao Avançado passando por Dashboard? Clique na imagem abaixo:

Planos Corporativos - Curso de Excel para empresas

Veja também:

Deixe seu comentário

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *