Como Usar Função Não.Disp no Excel – Passo a Passo

Como Usar Função Não.Disp no Excel – Passo a Passo

Pouca gente sabe, mas a função Não.Disp tem sim utilidade. Portanto, vamos então neste tutorial mostrar como e quando usar a função Não.Disp no Excel. Acompanhe o passo a passo abaixo e baixe o material para praticar a aula deste post.

Para que serve e como usar a função Não.Disp no Excel?

A função Não.Disp pode servir de extrema importância principalmente na observação de gráficos. Pois esta função mostra que o valor não está disponível.

 

Baixe esta Planilha disponível para download praticar o conteúdo desta aula!

Faça Download da planilha abaixo.

Autorizo a coleta e o tratamento dos meus dados para envio de material, inclusive publicidade, e adequação de minha experiência sobre produtos e/ou serviços da NINJA DO EXCEL, conforme informações prestadas AQUI

 

Como usar a função Não.Disp no Excel – Passo a Passo

Vamos pegar nossas informações e fazer um gráfico de pizza. Contudo, para isso, vamos selecionar dos dados. Portanto, clique na guia Inserir e em gráfico de pizza escolha algum que lhe agrade:

Criando Gráfico para Função Não.Disp

Agora adicionar os rótulos de dados em nosso gráfico:

Rótulos para a Função Não.Disp

Observe que, como não tivemos gastos com saúde, o gráfico mostra três cores, mas quatro rótulos de dados. Vamos corrigir isso?

É exatamente nesse momento que entra a função Não.Disp.

Clique na célula H4 e digite =NÃO.DISP():

Função Não.Disp no Excel

Cadastre seu e-mail aqui no blog para receber em primeira mão todas as novidades, posts e videoaulas que postarmos.

Receber conteúdos de Excel

Preencha abaixo para receber conteúdos avançados de Excel.

Fique tranquilo, seu e-mail está completamente SEGURO conosco!

É muito importante que você me adicione na sua lista de contatos, para que os próximos e-mails não caiam no SPAM. Adicione este e-mail: edson@ninjadoexcel.com.br

Pressione Enter e veja o gráfico agora que nosso rótulo zerado acabou de sumir

Gráfico com a Função Não.Disp

 

No entanto, para não ficarmos digitando esta função toda hora que precisarmos vamos automatizar usando a função SE.

Clique na célula H1 e digite: =SE(SOMA(B2:B4)=0;NÃO.DISP();SOMA(B2:B4)):

Excel Fórmulas: Função Não.Disp no Excel

Repita o processo com as demais áreas.

Para testarmos a funcionalidade, apague os valores referente a área de transportes e veja que tanto os rótulos quanto as cores desapareceram:

Curso de Excel Completo

Obviamente este recurso não se aplica somente ao gráfico de pizza, mas sim como também a qualquer outro tipo de gráfico no Excel.

Fizemos numa planilha simples, mas uma aplicação muito importante desta função são em Dashboard.

Curso de Excel Completo: Do Básico ao Avançado.

Quer aprender Excel do Básico ao Avançado passando por Dashboard? Clique na imagem abaixo:

Curso de Excel Completo Ninja do Excel

Aprenda mais sobre Excel: