PROCV com 2 condições (PROCV DUPLO)

PROCV com 2 condições (PROCV DUPLO)

Aprenda passo a passo como criar um PROCV com 2 condições no Excel (PROCV duplo).

Que o PROCV é uma das funções mais conhecidas no mundo, isso todo mundo já sabe, certo? Mas o que você não sabe é como essa função pode ser versátil.

Se você ainda não conhece o PROCV, clique aqui.

Ainda sim, muita gente se perde quando precisa buscar mais de uma referência na fórmula, e poucos sabem como resolver. Pensando nisso, fiz essa aula para sanar de vez essa dúvida usando um PROCV duplo, com duas condições no Excel!

Primeiro de tudo, faça o download da planilha para praticar clicando abaixo:

Donwload da Planilha de Excel

Se quiser acompanhar a videoaula, assista abaixo:  PROCV Duplo – 2 condições:

Sobre o PROCV Duplo

O PROCV Duplo serve para você colocar um PROCV dentro do outro. Isso serve para você localizar e juntar informações em mais de uma matriz. E quebra um galho, principalmente para os profissionais nas áreas fiscais e de impostos. Quer saber por quê? Eu te mostro neste passo a passo!

Analisando suas Matrizes

Na planilha que utilizei de exemplo, nós temos três matrizes

O que eu quero trazer é o imposto por região em porcentagem para cada cidade de forma automática de acordo com as informações que eu tenho. E para isso, vamos aplicar o PROCV duplo levando em consideração os tipos de tributação representados pelos números de 0 a 7 e suas respectivas regiões.

PROCV DUPLO Procv dentro de PROCV duas condições

Aplicando o primeiro PROCV para buscar a Região

O que eu preciso saber primeiro é qual região pertence cada estado. Na Matriz 1 essa informação não consta, porém na matriz 2 eu já tenho a representação de todos os estados e suas respectivas regiões.

PROCV DUPLO Procv dentro de PROCV duas condições

Vamos aplicar um PROCV simples para isso:

=PROCV(D2;

Onde D2 representa o valor procurado Acre.

PROCV DUPLO Procv dentro de PROCV duas condições

Agora, selecionamos a área da Matriz_tabela, que é toda essa informação da Matriz 2.

No índice_coluna, aplicamos o número 2, que representa a segunda coluna da matriz (Coluna Região); e na correspondência deixamos o valor em 0 para correspondência exata, ou seja, trazer exatamente a mesma informação que estamos pedindo em D2. Ficará assim:

=PROCV(D2;H2:I28; 2;0)

Não esquecer de fixar a referência da matriz para torná-la um valor absoluto. Para isso, basta selecionar o intervalo da referência na fórmula e apertar a tecla de atalho F4 no seu teclado.

=PROCV(D2;$H$2:$I$28; 2;0)

PROCV DUPLO Procv dentro de PROCV duas condições

Pronto, o primeiro PROCV está feito e funcionando. Faça o teste.

Aplicando o PROCV duplo para buscar o imposto

Agora, nós vamos incluir um novo PROCV dentro do primeiro, e para isso, clique duas vezes rapidamente na célula com a fórmula do primeiro PROCV e logo depois do símbolo igual “=” nós vamos puxar outro PROCV.

Dessa vez, o valor procurado desse segundo PROCV será o resultado do primeiro:

A matriz tabela agora, será a matriz do imposto por região:

Um Macete para o índice da coluna no PROCV DUPLO

Agora, para adicionar o número do índice da coluna, vamos usar um macete. Se você incluir apenas o número da coluna da matriz ele vai ficar fixo, e dará erro no resultado, pois você precisa buscar em todas as colunas do 0 ao 7.

Então, neste caso, você selecionará a célula referente ao número que quer buscar na matriz, porém deve-se atentar ao seguinte, o número que está na coluna, não será o mesmo da matriz:

Pois na matriz Imposto por região, as colunas são representadas da forma abaixo, então precisamos que o valor do índice seja 3 para atribuir o valor correto:

E para isso acontecer, vamos incluir a diferença na frente da célula que selecionarmos para o índice da coluna, assim, será sempre o número somando +2 para chegar no número correto das colunas. E na correspondência, colocaremos 0 para valor exato.

A fórmula ficará assim:

=PROCV(PROCV(D2;$H$2:$I$28; 2;0);K2:S2;C2+2;0)

Assim, a fórmula entenderá que o número 1 +2 é o índice da coluna, ou seja, na coluna 3 está representado o valor da tributação 1.

Não esqueça de Fixar o segundo intervalo utilizando a tecla F4

=PROCV(PROCV(D2;$H$2:$I$28; 2;0);$K$2:$S$2;C2+2;0)

Adicionando as casas decimais

Não esqueça de aumentar as casas decimais para ficar o mesmo valor da matriz de Imposto por Região.

E pronto! Basta aplicar nas células abaixo e seu PROCV Duplo estará feito.

E para você que quer aprender PROCV e muito mais, não deixe de conhecer meu curso de Excel Avançado!

curso de excel avançado

 

Mais aulas de PROCV para você:

Se você já gosta das aulas gratuitas aqui do Blog, então vai adorar as aulas do curso de Excel Avançado, clique aqui

Deixe seu comentário

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *