Como criar um Código Identificador no Excel

Hoje você vai aprender de forma pratica e fácil como criar um Código Identificador no Excel. Além de ser simples, isso é algo muito útil, pois caso esteja criando um sistema, por mais simples que seja, é necessário criar um código identificador, também conhecido como chave primaria ou primary key, para realizar o cruzamento de dados sem que tenhamos dados repetidos.

O CPF, por exemplo, é um código único. Seu CPF não é igual ao de mais ninguém e vice-versa.

Esta aula foi dúvida de uma aluna que me mandou o seguinte:

image.png

Clique aqui para baixar a planilha e acompanhar o tutorial sobre como criar um Código Identificador no Excel

Donwload da Planilha de Excel

Para criamos nosso código Identificador no Excel vamos precisar conhecer as funções CONCATENAR, SE e LIN.

curso de excel avançado

Clique na célula A2 e abra a função SE:

A lógica é a seguinte: se o campo cliente for preenchido ele vai gerar um código novo. Qual será o código? O número da linha, porém já deixaremos configurado para não precisarmos fazer tal cadastro.

Sua função SE deverá ficar assim: =SE(B2=””;””;CONCATENAR(“Cod “;LIN(A2)-1))

Vamos explicar essa fórmula: SE a célula B2 for preenchida a função SE vai chamar a função CONCATENAR que juntará a palavra “Cod” com o número da linha, no caso da linha B2. Como o resultado da linha seria 2, subtrai-se um para o primeiro valor ser 1.

Pressione Enter

Cadastre seu email aqui no blog para receber em primeira mão todas as novidades, posts e videoaulas que postarmos.

Receber conteúdos de Excel

Preencha abaixo para receber conteúdos avançados de Excel.

Fique tranquilo, seu e-mail está completamente <strong>SEGURO</strong> conosco!

É muito importante que você me adicione na sua lista de contatos, para que os próximos emails não caiam no SPAM. Adicione este email: edson@ninjadoexcel.com.br

Use a alça de preenchimento até uma grande quantidade de células como A500, por exemplo:

Como temos dados de clientes preenchidos até a célula B10, então apareceu automaticamente até Cod 9:

Preencha a célula B11:

Veja como o Cod 10 surgiu automaticamente.

Muito legal, né?

Uma vantagem de criarmos um código Identificador no Excel é que não vai aparecer código duplicado e sempre surgirá em ordem crescente.

Uma outra dica interessante é você proteger as células de códigos para ninguém apagar.

Quer aprender mais sobre Excel? Clique na imagem abaixo e conheça nossos pacotes promocionais. Aprenda tudo sobre Dashboard no Excel.

Curso de Excel Gráficos e Dashboards Ninja do Excel

Veja também:

Deixe seu comentário

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *