Criar frases automáticas no Excel

No Excel é praticamente impossível você garantir que sabe fazer tudo. Está disposto a aprender algo novo e deixar seu Excel ainda mais interativo? Então vamos fazer com que frases automáticas no Excel sejam retornadas.

Funciona assim, quando fazemos um cálculo normalmente o Excel nos retoma o valor. Por exemplo, R$ 100,00. Mas seria muito mais interessante se ele retornasse: “Você lucrou R$ 100,00” ou em uma situação adversa: “Seu prejuízo foi de R$ 100,00”.

Planilha disponível para donwload

Donwload da Planilha de Excel

Para realizar nossa tarefa de criar frases automáticas no Excel vamos precisar usar funções SE e CONCATENAR.

Nós temos uma planilha bem simples onde vamos lançar o valor de entrada e de saída e um determinado período.

Temos também um local onde será retornado o saldo que pode ser positivo ou negativo.

Clique na célula E7 e digite =SE(C7=0;””;

Abrindo função se para frases automáticas no Excel Ou seja, estamos dizendo para o Excel que se o valor que estiver na célula C7 for 0 então a célula E7 deve ficar limpa.

Continuemos nossa função SE. SE(C7>0;CONCATENAR(“Você lucrou R$ “;C7;”,00 reais”):

Primeira concatenação de frases automáticas no Excel

Estamos dizendo que se o saldo for positivo, ou seja, maior que 0 então chame a função CONCATENAR nos dará uma mensagem. Perceba que dentro da função CONCATENAR fazemos referência ao valor na célula C7.

Cadastre seu email aqui no blog para receber em primeira mão todas as novidades, posts e videoaulas que postarmos.

Receber conteúdos de Excel

Preencha abaixo para receber conteúdos avançados de Excel.

Fique tranquilo, seu e-mail está completamente <strong>SEGURO</strong> conosco!

É muito importante que você me adicione na sua lista de contatos, para que os próximos emails não caiam no SPAM. Adicione este email: edson@ninjadoexcel.com.br

Concluímos nossa função com o seguinte trecho: CONCATENAR(“Você teve um prejuízo de R$ “;C7;”,00 reais”):

Segunda concatenação de frases automáticas no Excel

Isto significa que se tivermos prejuízo, ou seja, se o resultado for menor que 0 então a mensagem dizendo que temos prejuízo será mostrada na tela.

Vamos testar?

Digite R$ 1.500,00 na célula C3 e R$ 1.000,00 na célula C4 e pressione Enter:

Lucro de frases automáticas no Excel

Viu que como o resultado ficou bem interessante?

Modifique o valor da célula C4 para R$ 2.000,00 para conferimos o novo resultado:

Prejuizo de frases automáticas no Excel

Gostou?

Conhece mais alguma maneira? Deixe nos comentários.

Grande abraço e até o próximo artigo 🙂

Chegou a hora de aprender Excel de forma completa!  Cursos de Excel com preços especiais!

Planos Corporativos - Curso de Excel para empresas

Veja também:

Deixe seu comentário

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *