PROCV com valores repetidos

 

Imagine a seguinte situação: você digite em seu PROCV um determinado valor e a função vai buscar o resultado. Fácil, não? Mas e se, por ventura, tivermos dois valores procurados iguais? Aí já complica um pouco, não? É por isso que você vai aprender agora a usar a função PROCV com valores repetidos.

Antes de mais nada peço que leia este tutorial até o final e com muita atenção, pois é contém muitos detalhes.

Baixe a planilha deste tutorial:

Donwload da Planilha de Excel

Você deve conhecer as funções:

Vejamos, temos uma planilha

Antes de irmos para o PROCV propriamente dito, vamos primeiro clicar na célula B3 e realizar a função CONTE.SE. Dentro da célula B3 digite =CONT.SE($C$3:C3;C3):

Contando para PROCV com valores repetidos

Esta função, vai contar e aplicar o valor de 1 em diante de acordo a sua ordem:

Resultado pra primeira contagem para PROCV com valores repetidos

Obs.: fixamos a primeira célula do intervalo, mas deixamos a segunda relativa.

Cadastre seu email aqui no blog para receber em primeira mão todas as novidades, posts e videoaulas que postarmos.

Receber conteúdos de Excel

Preencha abaixo para receber conteúdos avançados de Excel.

É muito importante que você me adicione na sua lista de contatos, para que os próximos emails não caiam no SPAM. Adicione este email: edson@ninjadoexcel.com.br

Use a alça de preenchimento e veja que sempre o valor é encontrado a primeira vez ela ganha o resultado 1. A segunda vez o valor 2. A terceira 3. Se tivéssemos mais ele seguiria a mesma linha:

Clique novamente na célula B3 e vamos concatenar, ou seja, juntar a célula com o Cód + o resultado que encontramos na função CONT.SE.

Clique duas vezes nesta célula e entre o sinal de = e a função digite: CONCATENAR(C3;”-“;

Concatenar e cont.se para PROCV com valores repetidos

Obs.: verifique as aspas.

O resultado deverá ser este: =CONCATENAR(C3;”-“;CONT.SE($C$3:C3;C3))

Use a alça de preenchimento até o final:

Valroes com códigos para PROCV com valores repetidos

Primeira parte da tarefa concluída com sucesso.

Agora vamos fazer nosso PROCV onde também vamos concatenar nosso Cód a ordem.

Clique na célula H3 e digite esta fórmula: =PROCV(CONCATENAR($H$2;”-“;G3);$B$3:$D$14;3;0)

Digitando PROCV com valores repetidos

Digite um código na célula H2:

Use a alça de preenchimento até o final:

Resultado final de PROCV com valores repetidos

Troque o código:

Gostou?

Conhece mais alguma maneira? Deixe nos comentários.

Grande abraço e até o próximo artigo 🙂

Chegou a hora de aprender Excel de forma completa!  Cursos de Excel com preços especiais!

Planos Corporativos - Curso de Excel para empresas

Veja também:

Deixe seu comentário

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *