Função FREQUÊNCIA no Excel

Hoje você vai aprender sobre uma função pouco conhecida, mas que certamente você vai gostar muito e nunca mais vai querer deixar de usar. A Função é: FREQUÊNCIA no Excel.

A função FREQUÊNCIA no Excel calcula a frequência com que determinados valores são informados num intervalo de dados em uma planilha. Ela faz isso a por meio de uma matriz.

Baixe a planilha para acompanhar o tutorial sobre a função FREQUÊNCIA no Excel

Donwload da Planilha de Excel

Você é o gerente de uma pequena loja e no final do dia gostaria de saber a frequência com que os produtos foram vendidos. Vamos fazer isso por meio da quantidade.

Conheça nossos cursos de excel online ninja do excel

O legal de usarmos a função FREQUÊNCIA no Excel é que podemos fazer o cálculo uma única vez para cada coluna.

O primeiro passo é termos os códigos exclusivos de todos os produtos. Para isso recomendo que você aprenda como copiar valores exclusivos no Excel.

Copirando valores exclusivos para Função FREQUÊNCIA no Excel

Feito isso, clique na célula G3 e digite =FREQÜÊNCIA(

Abrindo a Função FREQUÊNCIA no Excel

O primeiro argumento que a função FREQÜÊNCIA nos pede é a matriz_dados, neste caso selecione o intervalo de CÓD PRODUTO:

A matriz_bin é o intervalo referente a coluna CÓD PRODUTO, porém os códigos exclusivos:

Matriz_bin da Função FREQUÊNCIA no Excel

Pressione Enter para obtermos o resultado:

Mesmo que você fixe o intervalo da matriz_bin e use a alça de preenchimento isso acarretará em um erro:

Vamos corrigi-lo?

Selecione o intervalo onde queremos os resultados:

Selecionando intervalo para Função FREQUÊNCIA no Excel

Clique na barra de fórmula e pressione as teclas Ctrl + Shift + Enter, pois se trata de uma matriz:

Resultado correto da Função FREQUÊNCIA no Excel

E pronto. Temos agora o resultado correto:

Vamos tirar a prova?

Cadastre seu email aqui no blog para receber em primeira mão todas as novidades, posts e videoaulas que postarmos.

Receber conteúdos de Excel

Preencha abaixo para receber conteúdos avançados de Excel.

É muito importante que você me adicione na sua lista de contatos, para que os próximos emails não caiam no SPAM. Adicione este email: edson@ninjadoexcel.com.br

Para isso vamos usar a função CONT.SE:

Pronto. Temos o mesmo resultado:

Prova 1 de Função FREQUÊNCIA no Excel

Vamos tirar mais uma prova.

Clique na célula C24 e digite =CONT.NÚM(B3:B22):

CONTE.NUM PARA Função FREQUÊNCIA no Excel

Veja que o resultado foi 20, pois temos 20 produtos cadastrados:

Prova 2 PARTE 1 de Função FREQUÊNCIA no Excel

Clique na célula G9 e digite =SOMA(G3:G7):

Prova 2 PARTE 2 de Função FREQUÊNCIA no Excel

Veja que em ambos os resultados foram 20:

Resultado final

Conhece mais alguma maneira? Deixe nos comentários.

Grande abraço e até o próximo artigo 🙂

Chegou a hora de aprender Excel de forma completa!  Cursos de Excel com preços especiais!

Curso de Excel Gráficos e Dashboards Ninja do Excel

Veja também:

Deixe seu comentário

Deixe uma resposta

O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *